Difference between revisions of "Porting to 1.19"

From McJty Modding
Jump to: navigation, search
(build.gradle)
(Introduction)
Line 7: Line 7:
 
Do the following changes to [https://github.com/McJty/TutorialV3/blob/1.19/build.gradle build.gradle].
 
Do the following changes to [https://github.com/McJty/TutorialV3/blob/1.19/build.gradle build.gradle].
  
===Forge===
+
* Forge: First visit [https://files.minecraftforge.net/net/minecraftforge/forge/index_1.19.html The Forge Download Site] to see what the latest version of Forge is. Then change the minecraft dependency to that version. For example:
 
 
First visit [https://files.minecraftforge.net/net/minecraftforge/forge/index_1.19.html The Forge Download Site] to see what the latest version of Forge is. Then change the minecraft dependency to that version. For example:
 
  
 
  <syntaxhighlight lang="gradle">
 
  <syntaxhighlight lang="gradle">
Line 15: Line 13:
 
</syntaxhighlight>
 
</syntaxhighlight>
  
===Mappings===
+
* Mappings: Also you want to set the correct mappings. Check [https://github.com/ParchmentMC/Parchment/wiki/Getting-Started The Parchment Wiki] to find the latest version. As of this moment there are no parchment mappings for 1.19 so we use official mappings instead:
 
 
Also you want to set the correct mappings. Check [https://github.com/ParchmentMC/Parchment/wiki/Getting-Started The Parchment Wiki] to find the latest version. As of this moment there are no parchment mappings for 1.19 so we use official mappings instead:
 
  
 
  <syntaxhighlight lang="gradle">
 
  <syntaxhighlight lang="gradle">

Revision as of 11:59, 20 June 2022

Introduction

Here is a step by step description on how the tutorial mod was ported. As a reference you can find the 1.19 source of the tutorial here.

build.gradle

Do the following changes to build.gradle.

* Forge: First visit The Forge Download Site to see what the latest version of Forge is. Then change the minecraft dependency to that version. For example:
minecraft 'net.minecraftforge:forge:1.19-41.0.38'
* Mappings: Also you want to set the correct mappings. Check The Parchment Wiki to find the latest version. As of this moment there are no parchment mappings for 1.19 so we use official mappings instead:
mappings channel: 'official', version: "1.19"

JEI

We also want to get JEI. Consult The JEI wiki for more information. As of this writing we use this:

// compile against the JEI API but do not include it at runtime
compileOnly fg.deobf("mezz.jei:jei-1.19-common-api:${jei_version}")
compileOnly fg.deobf("mezz.jei:jei-1.19-forge-api:${jei_version}")
// at runtime, use the full JEI jar for Forge
runtimeOnly fg.deobf("mezz.jei:jei-1.19-forge:${jei_version}")

In gradle.properties we then set this: jei_version=11.0.0.206

TOP

Finally we want to include The One Probe. Check here to find what the latest version is The TOP Maven.

implementation fg.deobf(project.dependencies.create("mcjty.theoneprobe:theoneprobe:${top_version}") {
    transitive = false
})

And again in gradle.properties we put this: top_version=1.19-6.0.2-3